Sunday, April 29, 2012

FreeBSD Upgrade Perl 5.8.x to 5.10.x

How do I upgrade Perl version under FreeBSD operating system?

Perl (Practical Extraction and Report Language) is a language optimized for scanning arbitrary text files, extracting information from those text files, and printing reports based on that information. It's also a good language for many system management tasks. Perl can be easily upgrade to 5.10.1 from 5.8.x version using the following instructions.
lang/perl5.10 has been updated to 5.10.1. You should update everything that depends on perl. The easiest way to do that is to use "perl-after-upgrade" script supplied with lang/perl5.10.

Upgrade ports tree

Type the following command:
# portsnap fetch update

Upgrade Perl using portupgrade

Type the following commands:
# pkgdb -Ff
# portupgrade -o lang/perl5.10 -f perl-5.8.\*
# portupgrade -fr perl

Update all perl related stuff:
# portupgrade -f p5*

Upgrade Perl using portmaster

Type the following commands:
# portmaster -o lang/perl5.10 lang/perl5.8
# portmaster -r perl-

Notice: If the "perl-" glob matches more than one port you will need to specify the name of the perl directory in /var/db/pkg explicitly:
portmaster -Dr perl- /var/db/pkg/perl-5.10.1/

fixup FreeBSD packages that depend on perl

The standard procedure after a perl port (lang/perl5.X) upgrade is to basically reinstall all other packages that depend on perl. This is always a painful exercise. The perl-after-upgrade utility makes this process mostly unnecessary.
# perl-after-upgrade -f

Upgrade Other Packages

You also need to reinstall all other packages that depends upon perl. For example, amavisd-new. spamassassin, and clamav etc.
# cd /usr/ports/your-port-name
# make deinstall install

References:

  • Read /usr/ports/UPDATING file.
  • man pages portmaster, portupgrade, and perl-after-upgrade

No comments:

Post a Comment